I guys, i am kind of a newbie in Sybase ASE and encounter the following problem when querying my database using the isql tool.

I perform a query using the isql tool and the output shows me some of the columns (some text) as a hexadecimal characters or some other type.
I'm using a debian distribution to run the isql tool and get the output.

Ex:

1> select top 1 * from ServerCommon..SystemAlarmLog
2> go
AlarmLogID SALMessageID
MessageText






CreatedBy CreatedOn WarnLevel ErrorLevel
ChargingPointID
--------------- ------------
-----------------------------------------------------------------------
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
-----------------------------------------
----------- -------------------------- ----------- -----------
---------------
7901897 39
0x54006800650020006e0075006d0062006500720020006f00 6600200069006d0061006
700650073
00200072006500670069007300740065007200650064002000 69006e002000740068006
50020006c
00610073007400200068006f00750072002000680061007300 200065007800630065006
500640065
006400200074006800650020004500720072006f0072002000 6c0069006d00690074002
000640065
00660069006e00650064002000280064006100790054006900 6d0065005000650072006
9006f0064
0020002d0020005b00310035005d00

17 May 9 2013 7:44AM 115 57
1706


As you can see some of the fields are correct and others are showed in a char type that i suppose to be hexa.

Can anyone of you help me fix this issue?

Thanks in advanced