Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2012
    Posts
    32

    Unanswered: IBM DB2 Command line Window - Administrator disappears on windows server 2008 r2?

    I have installed IBM DB2 version 10 on windows server 2008 r2 machine. However i am unable to open it's command line window.

    For example: Whenever i try to open Command Windows - Administrator it appears and disappears in seconds. I happens for Command Window option as well in Db2.

    When i open a cmd window and type db2cmd it does not do anything ? The only thing that works is the command line processor window.

    What am i missing ?

  2. #2
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    Right click - Run As Administrator
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  3. #3
    Join Date
    Jun 2012
    Posts
    32
    Tried that still does not work ... it disappears in like seconds ?

  4. #4
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    I had this problem too, but I cannot remember exactly how I've solved it. It definetely was a Windows access rights problem. See if it's this:
    If you enable extended security on Windows Vista or Windows 2008, or higher, users must belong to the DB2ADMNS or DB2USERS group to run local DB2 commands and applications because of an extra security feature (User Access Control) that limits the privileges that local administrators have by default. If users do not belong to one of these groups, they will not have read access to local DB2 configuration or application data.
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  5. #5
    Join Date
    Jun 2012
    Posts
    32
    Thank you for your reply ... what i did was just reinstalled Db2 on my machine and it works fine now not sure what was the problem earlier.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •