Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2014
    Posts
    2

    Unanswered: pgadmin3 install problem with 9.2 64 bit on Centos 5.10

    I am trying to install pgadmin3_92 on Centos 5.10 and Postgresql92. When I do, I get complaints about missing libwx dependencies missing. What is my next step?

    Many thanks,
    Brian

    # cat /etc/redhat-release
    CentOS release 5.10 (Final)

    # yum search pgadmin3_92
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: mirror.sanctuaryhost.com
    * extras: mirror.umd.edu
    * updates: bay.uchicago.edu
    ====================================== Matched: pgadmin3_92 ================
    pgadmin3_92.i386 : Graphical client for PostgreSQL
    pgadmin3_92.x86_64 : Graphical client for PostgreSQL
    pgadmin3_92-debuginfo.i386 : Debug information for package pgadmin3_92
    pgadmin3_92-debuginfo.x86_64 : Debug information for package pgadmin3_92
    pgadmin3_92-docs.i386 : Documentation for pgAdmin3
    pgadmin3_92-docs.x86_64 : Documentation for pgAdmin3

    # yum install pgadmin3_92.x86_64
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: ftpmirror.your.org
    * extras: mirror.umd.edu
    * updates: centos.mirror.constant.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package pgadmin3_92.x86_64 0:1.18.1-2.rhel5 set to be updated
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.5)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: wxGTK for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_html-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_gtk2u_aui-2.8.so.0()(64bit) for package: pgadmin3_92
    ...
    ...
    --> Running transaction check
    ---> Package pgadmin3_92.x86_64 0:1.18.1-2.rhel5 set to be updated
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.5)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: pgadmin3_92
    ---> Package wxGTK.x86_64 0:2.8.12-1.el5 set to be updated
    --> Processing Dependency: wxBase = 2.8.12-1.el5 for package: wxGTK
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: wxGTK
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: wxGTK
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.10)(64bit) for package: wxGTK
    --> Processing Dependency: libgstinterfaces-0.10.so.0()(64bit) for package: wxGTK
    --> Processing Dependency: libgstreamer-0.10.so.0()(64bit) for package: wxGTK
    --> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: wxGTK
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: wxGTK
    --> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: wxGTK
    --> Running transaction check
    ---> Package SDL.x86_64 0:1.2.10-9.el5 set to be updated
    ---> Package gstreamer.x86_64 0:0.10.20-3.el5 set to be updated
    --> Processing Dependency: gstreamer-tools >= 0.10.20 for package: gstreamer
    ---> Package gstreamer-plugins-base.x86_64 0:0.10.20-3.0.1.el5_3 set to be updated
    --> Processing Dependency: libtheora.so.0(libtheora.so.1.0)(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libcdda_paranoia.so.0()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libXv.so.1()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libvorbisenc.so.2()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: liboil-0.3.so.0()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libogg.so.0()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libtheora.so.0()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libvorbis.so.0()(64bit) for package: gstreamer-plugins-base
    --> Processing Dependency: libcdda_interface.so.0()(64bit) for package: gstreamer-plugins-base
    ---> Package pgadmin3_92.x86_64 0:1.18.1-2.rhel5 set to be updated
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.5)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: pgadmin3_92
    ---> Package wxBase.i386 0:2.8.12-1.el5 set to be updated
    ---> Package wxGTK.x86_64 0:2.8.12-1.el5 set to be updated
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: wxGTK
    --> Running transaction check
    .....
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.5)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: pgadmin3_92
    --> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: pgadmin3_92
    ---> Package wxGTK.x86_64 0:2.8.12-1.el5 set to be updated
    --> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: wxGTK
    --> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: wxGTK
    ...
    --> Finished Dependency Resolution
    pgadmin3_92-1.18.1-2.rhel5.x86_64 from pgdg92 has depsolving problems
    --> Missing Dependency: libwx_baseu-2.8.so.0()(64bit) is needed by package pgadmin3_92-1.18.1-2.rhel5.x86_64 (pgdg92)
    ....
    Error: Missing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by package wxGTK-2.8.12-1.el5.x86_64 (pgdg92)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.


    # yum list postgres*
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: mirror.sanctuaryhost.com
    * extras: mirror.umd.edu
    * updates: mirror.fdcservers.net
    Installed Packages
    postgresql-libs.x86_64 8.1.23-6.el5_8 installed
    postgresql92.x86_64 9.2.6-1PGDG.rhel5 installed
    postgresql92-contrib.x86_64 9.2.6-1PGDG.rhel5 installed
    postgresql92-libs.x86_64 9.2.6-1PGDG.rhel5 installed
    postgresql92-server.x86_64 9.2.6-1PGDG.rhel5 installed
    Available Packages
    postgresql92-debuginfo.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-devel.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-docs.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-jdbc.x86_64 9.2.1002-1PGDG.rhel5 pgdg92
    postgresql92-jdbc-debuginfo.x86_64 9.2.1002-1PGDG.rhel5 pgdg92
    postgresql92-odbc.x86_64 09.02.0100-1PGDG.rhel5 pgdg92
    postgresql92-odbc-debuginfo.x86_64 09.02.0100-1PGDG.rhel5 pgdg92
    postgresql92-plperl.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-plpython.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-pltcl.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql92-test.x86_64 9.2.6-1PGDG.rhel5 pgdg92
    postgresql_autodoc.noarch 1.41-1.rhel5 pgdg92

  2. #2
    Join Date
    Feb 2014
    Posts
    2

    re: pgadmin3 install problem with 9.2 64 bit on Centos 5.10

    I figured out the Windows version of pgadmin would suffice. Just point pgadmin to the Linux server. No need for pgadmin directly on Centos 5.10.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •