Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2012
    Posts
    16

    Unanswered: Upgrade to 10.5FP1 failed

    Hi
    We upgraded DB2 Windows on 2008R2 from 10.1GA to 10.5FP1 version.We made db2ckupgrade
    without errors. Upgrade was made as described in SAP DB6 Upgrade Guide -
    exactly same steps - Work with existing . We had following
    errors "THE UPGRADE OF THE INSTANCE "DB2" HAS FAILED. THE RETURN VALUE
    IS "1"." and error about updating database parameters. But Setup was
    completed successfully and we rebooted server as suggested. Now when we
    trying to start DB2 service DB2RSO-0 we had error: "The DB2 -
    SAPDB2RSO -
    DB2RSO-0 service terminated with service-specific error %%-1042." and indb2diag.log:
    2014-03-07-08.46.18.056000+060 I355203F401 LEVEL: Severe
    PID : 4748 TID : 5432 PROC : wmiprvse.exe
    INSTANCE: DB2RSO NODE : 000
    HOSTNAME: sr-00090
    EDUID : 5432
    FUNCTION: DB2 UDB, config/install, sqlfcsys, probe:1
    RETCODE : ZRC=0xFFFFEC41=-5055
    SQL5055C The content of the database configuration file is
    not
    valid.

    db2ilist is returnig DB2RSO
    but db2level is returning:
    SQL1022C There is not enough memory available to process the command.

    and db2set is returning nothing

    Any suggestions besides restoring from backup ?
    Regards
    MArcin

  2. #2
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    What's the 'release level' reported by db2 get dbm cfg and db2 get db cfg for <db name>?

  3. #3
    Join Date
    Apr 2012
    Posts
    1,034
    Provided Answers: 18
    Give more precise facts - What was the exact error message about "error about updating database parameters"?

    The instance cannot start if the instance-upgrade failed.

    Give the relevant parts of the db2diag.log from the point where the db2 instance starts to get upgraded to the point where the instance upgrade fails.

  4. #4
    Join Date
    Mar 2012
    Posts
    16
    Sorry for delay but finally solved it This DB has long history , was upgraded from 9.1 to 9.7 then 10.1 and finally 10.5
    The problem was with Windows DB2_EXTSECURITY mechanism.
    There were two pair of groups DB2ADMNS and DB2USERS (domain and local ones) created and i've choosen wrong one during setup phase. And in the end db2iupgrade failed and thats why db2tools were not working and db2 windows service too.
    I've uninstalled db2 software completely , then install new one , catalog db , restore parameters and correct security attributes using db2extsec tool.
    Then repeated db2iupgrade and upgrade db.
    Luckily it was not core environment so i was able to spend some hours on that.
    SAP support wanted to restore from backup of course (as with near every issue reported there)
    Regards
    Marcin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •