Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2012
    Posts
    23

    Unanswered: DB2 Rollforward issue

    Hi,

    In my environment we are using DB2 v9.7 on AIX 6.1 version.

    I restored full database backup using online include logs with redirect restore option.it done successfully.later as per my requirement i have to restore online delta backup with include logs.So when i am applying delta backup on full backup i used the following commands.


    bash-3.2$ db2 restore db dogear incremental automatic taken at 20140504215454
    SQL2539W Warning! Restoring to an existing database that is the same as the
    backup image database. The database files will be deleted.
    Do you want to continue ? (y/n) y
    DB20000I The RESTORE DATABASE command completed successfully.

    after i tried to roll forward the database by using below command.


    bash-3.2$ db2 "rollforward db dogear to end of logs and stop overflow log path ('/tmp/logtarget/') noretrieve"
    SQL4970N Roll-forward recovery on database "DOGEAR" cannot reach the
    specified stop point (end-of-log or point-in-time) on database partition(s)
    "0". Roll-forward recovery processing has halted on log file "S0000850.LOG".

    i tried with many more roll forward options but no luck So Could you please suggest what are all the steps that i have to follow for completing this rollforward.
    Any help greatly Appreciated.

  2. #2
    Join Date
    Jul 2013
    Location
    Moscow, Russia
    Posts
    666
    Provided Answers: 55
    Hi,

    What is the full path to the S0000850.LOG log file and does the instance owner have appropriate OS permissions on this file?
    What's the result of:
    db2 rollforward db dogear query status
    ?
    Regards,
    Mark.

  3. #3
    Join Date
    Apr 2012
    Posts
    156
    Adding to Mark.b's comment check the db config for the location of the log directory that is being used by the database and copy log S0000850.LOG to that location (double check permissions as well)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •