Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2013
    Posts
    31

    Unanswered: SQL2563W The restore process has completed successfully, but one or more table spac

    Hi,

    I have recently restored a database from a backup file. After the restore I got the following error.
    SQL2563W The restore process has completed successfully, but one or more
    table spaces from the backup were not restored.

    I even tried redirect restore, but it still throws the same warning.
    I Checked the containers allocated to each of the database, I did not find the container for one tablespace. Is there any reason the container wouldnt get created ? Is there any way i can create this container manually & assign it to the tablespace? Or is there any option to restore the db without getting the above warning?

    DB Version:9.1
    OS:Windows Server 2003.
    Any help would be appreciated. Thanks

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    I'd start with looking in the diagnostic log (db2diag.log) to determine why one of the tablespaces was not restored.
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Jul 2013
    Posts
    31
    Thank you for your reply. I checked the log & found out that the space wasn't enough to create the tablespace. Im restoring it now

  4. #4
    Join Date
    Dec 2007
    Location
    Richmond, VA
    Posts
    1,328
    Provided Answers: 5
    funny, we just had similar today was due to performing a redirected restore from prod to QA. The issue arose because containers were different sizes, but in QA machine they were rebuilt by our restore script, but due to now the QA HADR standby machine having different container size we got the 2563. Solution was to do a redirected restore from QA primary to QA standby, then we tried redirected restore from prod to QA and all worked fine.
    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •