Results 1 to 5 of 5

Thread: cbo to subform

  1. #1
    Join Date
    Jul 2004
    Posts
    214

    Unanswered: cbo to subform

    All; using access 2010. I had a blank form. I want use the form to put a combo box for custid. I use a query based on a table with custid and maxdescription for the record source. I created the combo box. Then I inserted a subform with custid description and other data to appear as datasheet view. During the insertion of the subform; it suggested that I use the maxdescription as link master and address as child link which I thought was odd. I changed it to custid for both master and child links. When I view the form; I used the combo box to select one of the custidís that I know is in the subform. It didnít select anything. Iíve done this hundreds of times and I canít find whatís wrong! I planned to put code to filter; but this basic wizard should work without code! My initial thought was the datatype for both master and child links are text; but I have used this datatype in links before. Please help me figure this out.

  2. #2
    Join Date
    Apr 2014
    Location
    Kentucky
    Posts
    496
    Provided Answers: 24
    no need for subform. (i answered this on the other forum)
    Unless you need the subform for something?

  3. #3
    Join Date
    Jul 2004
    Posts
    214
    Thank you for replying. I believed I need the subform because it has many records with different info for multiple states for instance and the subform is in dataview view to easily display information.

  4. #4
    Join Date
    Apr 2014
    Location
    Kentucky
    Posts
    496
    Provided Answers: 24
    This still can be done w/o a sub form. Put the cboBox on the form HEADER where the form is a Continuous Forms (your mult record list)
    Pick from cbo, filter me.filter.

  5. #5
    Join Date
    Jul 2004
    Posts
    214
    Ok. I found the problem. Apparently; you have to have the same named field in both recordsource of the form and subform. My recordsource field was cus_id oppose to the subform cust_id. I donít remember that being the case as long as the datatypes matched and it is the same data. I further thought as long as the subform and the combo box matched datatype and data it would work. Thanks again for all your suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •