Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2010
    Posts
    23
    Provided Answers: 1

    Unanswered: System error from db2start in Windows after installing service pack

    Hi.

    Windows 7. DB2 Enterprise Server Edition 10.1. Only one instance. Working yesterday.

    This morning, I downloaded and installed Service Pack 4.

    I had run db2stop successfully before beginning. Nonetheless, the installer prompted me that there were tasks running, and asked if it should stop them, with the suggestion that I might consider saying "no". But this is a completely private system for testing and I am the only user ... so I said "yes".

    The installation completed, but now every time I boot, DB2 is not started. When I try db2start, I get SQL1042C An unexpected system error occurred.

    I'll attach the dbdiag.log messages. Any suggestions gratefully received.

    Art
    Attached Files Attached Files

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Oct 2010
    Posts
    23
    Provided Answers: 1
    It certainly did! Thank you.

  4. #4
    Join Date
    Oct 2010
    Posts
    23
    Provided Answers: 1
    One last remark, in case anyone else has this issue. The fix suggested by that link got me to the point at which I could start db2 manually after each Windows restart.

    But, on checking the Windows Services panel, I saw that the service DB2 - DB2COPY1 - DB2-0 was marked for manual start. I changed it to Automatic start and rebooted, and now DB2 comes up normally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •