Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2014
    Posts
    2

    Unanswered: Password expiration issue

    I'm receiving an error message on DB2 9.7.0.7 running on AIX 7.1 and authenticating using QAS 4.0.3. If I log in to the database server and try to connect using "db2 connect to databasename user username using password" I get the following error message: SQL30082N Security processing failed with reason "1" ("PASSWORD EXPIRED").
    SQLSTATE=08001. If I try to connect using "db2 connect to databasename" it works fine. I also get this error message trying to connect through any database utility on my local machine. My DBAUTH is set to OSAUTH and I feel like QAS is authenticating properly since I'm able to log into the server. Any ideas?

  2. #2
    Join Date
    Apr 2012
    Posts
    1,035
    Provided Answers: 18
    Is this a new installation of Quest-Authentication-Services with this db2 v9.7.0.7?
    Or is it an upgrade?
    Try increasing the DIAGLEVEL to 4 for the db2 instance, then repeat the "db2 connect to $dbame user $userid using $password" and see what's in the db2diag.log
    If you are able to increase the diagnostic level for the QAS services, then what information do you see there.
    You may get better support from Dell (who now owns/supports this software QAS) or Dell forums. IBM does not support QAS.

  3. #3
    Join Date
    Jun 2014
    Posts
    2
    It's a new installation, with the DIAGLEVEL at 4, I get a "Password validation for user username failed with rc = -2146500508", which is a password expired.

  4. #4
    Join Date
    Apr 2012
    Posts
    1,035
    Provided Answers: 18
    Verify with the supplier of QAS that they certified specifically with DB2 v9.7 on AIX 7.1.

    Then enable all diagnostic capabilities offered by QAS and study those, as previously suggested.

    It may be that additional configuration is necessary...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •