Hello all,

I recently upgraded a postgresql 9.2.7 db to 9.3 on redhat enterprise 7. It seemed to go well and was working for a few days. I had to restart the db and now I get the below error when i run "pg_ctl start".

FATAL: database files are incompatible with server
< 2014-07-14 11:37:41.189 EDT >DETAIL: The data directory was initialized by PostgreSQL version 9.3, which is not compatible with this version 9.2.7.

I am, however, able to start the database with the following command:

/usr/pgsql-9.3/bin/pg_ctl -D /var/lib/pgsql/9.3/data/ -l logfile start

Running "echo $PGDATA" gives me /var/lib/pgsql/9.3/data

Does anybody have information on how I can get pg_ctl start to work again?