Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2014
    Posts
    4

    Unanswered: Seaching in a password protected form

    I have what seems to be an advanced question.

    I have a form based off of a query. When I pull up the form it asks for the proper perameter (ID Number) then asks for the user name and password. It was working great

    ....then.....

    I tried to edit some of the fields in this form. It wouldn't let me, I went to the form properties and turned 'data entry' on and now the form won't ask for the ID number anymore when it opens. Is there anyway for me to have the form be editable and still do what I originally wanted it to do? It's pretty critical that this form be password protected and prompt you to pull up the proper record.

  2. #2
    Join Date
    Sep 2014
    Posts
    4
    I figured it out. I copy and pasted some of my fields from another form to try and cut down on the design and layout time and it messed something up. I made the query and form over again from scratch and it works now....

    wierd problem though since all the stuff looks exactly that same, just wouldn't work

  3. #3
    Join Date
    Jun 2005
    Location
    Richmond, Virginia USA
    Posts
    2,763
    Provided Answers: 19
    Quote Originally Posted by slyce476 View Post

    ...I went to the form properties and turned 'data entry' on and now the form won't ask for the ID number anymore when it opens...
    If by "turned 'data entry' on" you mean you set the Data Entry Property to Yes, the problem was that this property only allows for the addition of New Records, it doesn't allow you to view existing Records. Because of this it couldn't be used as a search form and hence didn't need to ask for the ID number.

    The property name Data Entry is very misleading; common sense would dictate that it has to be set set to Yes in order to...enter data, and that's not true! The AllowEdits and AllowAdditions Properties control you ability to enter data. Once again, setting Data Entry to Yes merely restricts you to entering New Records.

    My guess is that when you recreated your Form you left Data Entry to its default setting, which is No.

    Linq ;0)>
    Hope this helps!

    The problem with making anything foolproof...is that fools are so darn ingenious!

    All posts/responses based on Access 2003/2007

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •