Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2014
    Posts
    3

    Unanswered: "0" appearing in empty math fields

    Hello,

    I am using bdb to creat an invoice form.

    The invoice should have like 8 lines, each line presents an item with its description and price.

    I used a math field for the price.
    Whenever a math field is note used (left empty), it shows a value "0" when I print the report. While it should only appear as blank line.
    I set the field to invisible by rule only when edit (value entered), but still appearing "0"


    screenshots for both the form and the report.

    https://lh4.googleusercontent.com/-E...oadfile-2.jpeg

    https://lh5.googleusercontent.com/-f...oadfile-1.jpeg


    Please help how to hide the zeros in the report.

    Thank you in advance.

  2. #2
    Join Date
    Jun 2012
    Posts
    163
    Provided Answers: 1
    Dear papacito:

    (suena raro, porque habla español, cambiate el nombre jajja)

    i think that you should try to edit the math format, (where you set the number of decimals and so...) if you are using a spanish version, please, note that fore some reason, the traduction messed up the format, so even if using the asistants you get a format like this "matematicas ##.00, you have to manually change it to english, "math ##.00

    play with the options untill you get what you need, but almost for shure, you have a format issue.

    best regards

    fer from mexico

  3. #3
    Join Date
    Jul 2012
    Posts
    94
    Provided Answers: 4
    Need to add |NO_ZERO| in format. See attachment.

    Click image for larger version. 

Name:	No-Zero.PNG 
Views:	26 
Size:	13.1 KB 
ID:	15886
    I do not know English well. I am using Google Translate for translation. Please do not laugh my sentences.

  4. #4
    Join Date
    Oct 2014
    Posts
    3

    Post Thank you @MacHeuS

    @MacHeuS: Thank you very much for your help. It worked.


  5. #5
    Join Date
    Oct 2014
    Posts
    3

    Post Thank you @MacHeuS

    @MacHeuS thank you very much for the help.
    It worked!

    Quote Originally Posted by MacHeuS View Post
    Need to add |NO_ZERO| in format. See attachment.

    Click image for larger version. 

Name:	No-Zero.PNG 
Views:	26 
Size:	13.1 KB 
ID:	15886

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •