Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2004
    Posts
    545
    Provided Answers: 4

    Unanswered: ASE15 Auditing - errorlog entry: current audit table has been changed by <user> ...

    After setting up auditing successfully I discover this in my error logafter an audittable switch: The configuration option 'current audit table' has been changed by <username> from 1 to 2
    <username> is the loginname o the DBA that setup the auditing, and I can trace that back to the field loginame in sysobjects. I don't want a specific loginname to be mentioned, can I alter the value in sysobjects to NULL, like it is for all the other objects?
    Last edited by Martijnvs; 10-14-14 at 14:50.
    I'm not crazy, I'm an aeroplane!

  2. #2
    Join Date
    Jan 2012
    Location
    Lisbon
    Posts
    115
    Provided Answers: 1
    Hi,
    I'm not sure I got your question right, however the errorlog message states that your audititing table has been changed from "sysaudits_01" to "sysaudits_02".
    So when you installed sybsecurity and set the Auditing options you want to audit on, they will be saved on sysaudits_02.

    What is the problem with having the loginname on the sysobjects? If you want other logins to access it provide permisssions to them.
    I never update that column, but it should be ok, test it out first in a dev or tst env just to be sure.

  3. #3
    Join Date
    Jan 2004
    Posts
    545
    Provided Answers: 4
    Auditing works perfectly, the threshold procedure switches the current audittable to the next one when the threshold is reached. That is what the message in the errorlog says. I just don't want to have a loginname displayed there if that's possible. I figured that if I change the loginname of the thresholdprocedure in sysobjects, the loginname in the errorlog message would also change/disappear.

    It's a nice to have
    I'm not crazy, I'm an aeroplane!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •