Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2009

    Unanswered: Restore Issue : TRANSPORT and USERSPACE1

    Hello Gurus,

    My DB servers are on V10.5 FP 2. requirement is to restore a Full DB backup onto another existing DB. Target database has some tables which are not in the source database. So basically I want to 'restore all the tables of the source database + want to retain tables which are present on the target DB but not in the backup image of the source DB'. I tried below options without any success -

    1. Rebuild target DB with the tablespaces of the source database. (Full backup)

    Result : Here, All the tables from the Full Backup image of the source Database are restored but I lost tables of the target DB. those are no more after rebuilt.

    2. Use 'Transport' option with the Restore. it transports schema/tablespaces

    Result : Ran into one strange issue. Seems this option can't work when Tables in the source database are in default tablespace ie. USERSPACE. This utility can't transport USERSPACE1. otherwise it would have worked in my case.

    I need help to do the right approach for the given scenario.

    Thanks in Advance

  2. #2
    Join Date
    Apr 2012
    Provided Answers: 17
    You have not given any sizing facts / volumetrics to let us assess the merits of one approach versus another, or how disjoint are the sets of tables/objects/tablespaces between the two databases.

    If transportable schemas are not an option, then at least two other options exist. For example, not using-backup-restore at all, but simply creating the missing objects in the target-db and scripting a load-from-remote-cursor to populate tables in the target from the source. Another example approach is to use backup-restore but export the tables-to-preserve from the target-db first, and load them after the restore-from-source-image finishes successfully

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts