Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2013
    Posts
    5

    Unanswered: Pervasive Client/Server 11 and Windows 8

    Have a customer in a client/server environment. Most of their client machines are Windows 7 with some XP still hanging around. They just replaced an XP client with a Windows 8.1 machine. The Win 8 box gets a 3012 error (can't find the engine). I have opened the firewall for w3dbsmgr, and I can connect to the server using the Pervasive License Administrator and see the active licensing.
    Checking the version on the server, I see that their current version is 11.2. I found one note somewhere that said we had to be using 11.3. The workstation client is 11.3.
    I will be upgrading the server engine this evening to 11.3...wondering if anyone else has any suggestions. Note, the network access to the server (Svr 2008) is correct.

  2. #2
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    From the description, it should work. Does the 3012 occur with Function Executor or just the application?
    Can you connect using the Pervasive Control Center to read data from the server?
    If this is an application specific issue, is there a configuration setting that might be pointing to the wrong location? If the application uses a mapped drive, does the mapped drive exist and point to the same location as on other machines?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Aug 2013
    Posts
    5

    Windows 8

    There is a mapped drive, and it is connected to the server. User permissions are in place and correct (same as 7 other users). If I open the control center, I can see the databases, including the unique one our app creates, on the server. I can also read the license information. I get the 3012 immediately as I attempt to access the database across the network. I'm assuming it's the Windows 8.1 thing.....if that does not correct it later today, will repost. Thanks for reply !

  4. #4
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    What do settings for "Use Local MicroKernel Engine" and " Use Remote MicroKernel Engine" like the screen shot below show?
    Click image for larger version. 

Name:	PvswSettings.png 
Views:	1 
Size:	4.7 KB 
ID:	15952

    What exactly was installed on the Windows 8.1 machine? What's in the PVSW.LOG file?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •