I've got a MySQL cluster where I build a new database for each customer. The databases are relatively small in size and I currently only have 4 databases on this cluster. I just tried to run my script to create a database for another customer and received this error:

ERROR 1114 (HY000) at line 180: The table 'TABLE_locations' is full

I've verified that I have plenty of Index and Data memory and increased the MaxNoOfAttributes just in case but I'm still having the issue. I've pasted my config.ini file from the management server below and just XX'ed out directory names. I'm not sure what else to try at this point to overcome this error? Sincerely appreciate any help!


Code:
[ndbd default]
# Global NDBD Configuration for All Data Nodes
NoOfReplicas=2          # Number of replicas
DataMemory=1024M         # Memory Allocation for data storage
IndexMemory=512M        # Memory Allocation for index storage
MaxNoOfAttributes=10000 #Maximum number of attributes

[ndb_mgmd]
# HOST003 (Management Node Options)
HostName=10.100.X.X
DataDir=/XXX/MYSQL
NodeId=1

[ndbd]
# HOST004 (Data Node Options)
HostName=10.100.X.X
DataDir=/XXX/MYSQL
NodeId=20

[ndbd]
# HOST005 (Data Node Options)
HostName=10.100.X.X
DataDir=/XXX/MYSQL
my.cnf content from management node:

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
InnoDB File Path:
Code:
| innodb_data_file_path                                  | ibdata1:12M:autoextend
Database Sizes:

Code:
+--------------------+---------------+
| DB Name            | DB Size in MB |
+--------------------+---------------+
| CP_4000002         |          19.4 |
| CP_4000003         |           8.9 |
| CP_4000004         |           5.7 |
| CP_4000005         |           2.8 |
| information_schema |           0.0 |
| mysql              |           0.8 |
| ndbinfo            |           0.0 |
| performance_schema |           0.0 |
+--------------------+---------------+