Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2015
    Posts
    31

    Unanswered: Converting Excel Formula into Access SQL

    Hello everyone,

    I've been having problems with a formula that i have in Excel that i wish to convert into access in order to play around with my database.
    Can somebody please tell me where i'm going wrong ?


    OTD Réel: VraiFaux(Ou([011- Extraction FA ENSEMBLE]![OTD Prév]=1;Et([livraisons]![Dt BL]<=[livraisons]![Dt Prom];[livraisons]![Qté facturée]=[livraisons]![Qté cde];"1")))VraiFaux([livraisons]![Dt BL]<=[livraisons]![Dt Prom]; [livraisons]![Qté facturée]/[livraisons]![Qté cde];"0")

    =SI(OU(D3=1;ET(B3<=C3;E3=F3));1;SI(B3<=C3;E3/F3;0))*

    B-->Date BL
    C-->Date Promise
    D--> OTD Prev
    E-->Qté facturée
    F-->Qté cmdé

    Kind regards !

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    VraiFaux is?
    is that an function in public Excel or a user written function
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    Jun 2005
    Location
    Richmond, Virginia USA
    Posts
    2,763
    Provided Answers: 19
    According to Babelfish VraiFaux is French for IIF(), which, according to Excel Help, appears to work exactly as it does in Access!

    Linq ;0)>
    Last edited by Missinglinq; 05-09-15 at 20:19.
    Hope this helps!

    The problem with making anything foolproof...is that fools are so darn ingenious!

    All posts/responses based on Access 2003/2007

  4. #4
    Join Date
    Mar 2015
    Posts
    31
    Sorry for not clarifying the vocabulary !

    VraiFaux --> Iff()
    Et--> And
    Ou--> Or

    Excusez moi !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •