Results 1 to 11 of 11
  1. #1
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789

    Unanswered: Sql express 2014

    Hello I have a database called Lab Wizard that uses SQL express which is installed on windows 2008 r2 server, I am trying to make it so that the client computers can access the SQL through the ODBC DRIVER but I keep getting a TCP IP connection error. Can anyone tell me what I'm doing wrong, I'm drawing a blank here. I already configured port 1433 in All IPs in the Configurations Manager
    Last edited by desireemm; 05-21-15 at 02:54.

  2. #2
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    Have you configured up the firewall to open up port 1433?
    George
    Home | Blog

  3. #3
    Join Date
    Nov 2004
    Location
    on the wrong server
    Posts
    8,835
    Provided Answers: 6
    I assume the TCP/IP protocol is enabled in the SQL Server Network Configuration thing-a-majig in the Configuration Manager.
    “If one brings so much courage to this world the world has to kill them or break them, so of course it kills them. The world breaks every one and afterward many are strong at the broken places. But those that will not break it kills. It kills the very good and the very gentle and the very brave impartially. If you are none of these you can be sure it will kill you too but there will be no special hurry.” Earnest Hemingway, A Farewell To Arms.

  4. #4
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    By default, SQL Express does not listen on any network interface, so that will have to be enabled, first. You will then need to configure the SQL Express instance to use a static port, rather than be dynamic, and potentially pick a new port after a reboot. After all of that, you should create inbound rules for 1) TCP on the port you configured for SQL Express and 2) UDP for port 1434 (SQL Browser). SQL Express is rarely installed as a default instance.

  5. #5
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    Quote Originally Posted by Thrasymachus View Post
    I assume the TCP/IP protocol is enabled in the SQL Server Network Configuration thing-a-majig in the Configuration Manager.
    HI Thrasymachus good to see you, and yes it is

  6. #6
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    Which version of SQL Express is the Lab Works application using? I'm pretty sure that these directions will help. Note that you can navigate to other SQL Server versions using the drop down near the top of the page.

    -PatP
    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  7. #7
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    HI Pat the users are using Lab Wizard 10 which uses sql express 2014

  8. #8
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    If Lab Wizard 10 is using SQL Express 2014, then the directions on the page at the link I provided ought to be exactly what you need!

    -PatP
    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  9. #9
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    ok I am finally able to connect through the ODBC driver thank you

  10. #10
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    Just curious, but what "Majik dance" did you need to do to get the ODBC connection working? It will help people who view this thread later if you add a comment describing what change or changes you made that fixed your problem.

    -PatP
    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  11. #11
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    Your right Pat I keep forgetting to do that. All I did was
    To enable a server network protocol


    1.In SQL Server Configuration Manager, in the console pane, expand SQL Server Network Configuration.



    2.In the console pane, click Protocols for <instance name>.



    3.In the details pane, right-click the protocol you want to change, and then click Enable or Disable.



    4.In the console pane, click SQL Server Services.



    5.In the details pane, right-click SQL Server (<instance name>), and then click Restart, to stop and restart the SQL Server service.


    also in the configuration manager I put 1433 under All IP under the instance I went to TCP IP properties under IP address tab in IP All 1433 and made enabled it also did a restart under SQL Server Browser.. Made sure the group had permissions to connect to it on the server also.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •