Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2014
    Posts
    294

    Unanswered: Sql error: 4499, SQLSTATE=08001

    Hi,

    I have installed db2 express c on redhat linux.I can able to start the database & I can able to do all the operations on db2.Now I m trying to connect to through IBM data studio , I m getting the below error.

    Error:
    com.ibm.db2.jcc.am.DisconnectNonTransientConnectio nException: [jcc][t4][2043][11
    550][3.61.86] Exception java.net.ConnectException: Error opening socket to server /192.168.61.140 on port 50,000 with message: Connection timed out: connect. ERRORCODE=-4499, SQLSTATE=08001

    I m a learner in linux activities. So I request you to kindly help me

    Thanks in advance

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Is 192.168.61.140 local or remote? If remote, can you access the database remotely from the same computer through the CLP?

    Andy

  3. #3
    Join Date
    Apr 2012
    Posts
    1,034
    Provided Answers: 18
    If it is a modern version of RHEL be sure to open the relevant ports for the db2 instance(s) with the tool called
    system-config-firewall or equivalent command-line methods.
    Otherwise other environments (such as windows laptops etc running the Data Studio ) will be unable to connect to DB2.
    Additionally if there are other firewalls between the RHEL lpar and the hostname running DataStudio then each firewall along the route needs the relevant port to be opened.

    [ Separately, if you know how to use SSH tunnelling, the default port 22 is normally open and you can tunnel db2 traffic over the SSH port which works well - although you need to RTFM carefully to set it up properly - that is an SSH matter and not a DB2 matter]

  4. #4
    Join Date
    Jul 2014
    Posts
    294
    Yes Db2 is on VM box.
    From my local machine I can't able to ping the remote machine.

    [db2inst1@localhost ~]$ db2set -all
    [i] DB2_DEFERRED_PREPARE_SEMANTICS=YES
    [i] DB2_COMPATIBILITY_VECTOR=ORA
    [i] DB2_GRP_LOOKUP=LOCAL
    [i] DB2COMM=TCPIP
    [i] DB2AUTOSTART=YES
    [g] DB2_COMPATIBILITY_VECTOR=MYS
    [g] DB2SYSTEM=localhost.localdomain
    [g] DB2INSTDEF=db2inst1
    [g] DB2ADMINSERVER=dasusr1

    this is my SVCENAME = db2c_db2inst1
    this is my value in etc/services = db2c_db2inst1 50000/tcp

    I have set all the necessary parameters .I tried to turn off iptables as
    service iptables stop

    Now iptables are also inactive.
    Still I m getting the same error
    Last edited by HABBIE; 06-26-15 at 08:58.

  5. #5
    Join Date
    Jul 2014
    Posts
    294
    I found the solution for this. On my VM box, Iptables are turned off.
    Service iptables status

    service iptables restart

    From windows command prompt
    telnet IP 50000,

    Empty screen will be opened & It symbols able to ping from windows machine to Db2 on VM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •