I need to restore a 2.5 Joomla! website. I've got a backed up SQL database from July. What I need to know is does the Joomla! version need to be the same as when you took the database backup? In other words, if you were using Joomla! 2.5 .24 when you backed up the database, if I'm going to reinstall all the files and then connect to that database, do I need to use all the files from a new Joomla! 2.5 .24 package?