Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2015
    Posts
    1

    Question Unanswered: Opening a form in accesss with a blank subform

    Hi All
    Need some help please. I'm not an official IT expert however I'm pretty good at figuring some processes out.
    I've created an invoice form (Point of Sale) for my Nail Salon in access using 3 tables.
    Main Form
    Table 1. "Invoices" - this has: Invoice no (Autonumber), Invoice Date, Invoice To.
    I've worked out how open a blank record for this with "New", "Refresh", "Save & New"
    Subform
    Table 2: "Therapist Info", I've created a lookup field for this - works perfectly
    Table 3: "Treatments", created a lookup field and relationship so that when a treatment is selected, the cost automatically displays.
    I then have calculated fields for: Quantity, Tip, Amount Paid and Change. - These all work perfectly.

    What I can't seem to be able to do is get the subform to open a blank record when I've saved the main form.
    I get a blank main form, but all the records in the subform show, I've tried entering "GoToNewRecord" at onload but I don't seem to be getting it right.
    What am I doing wrong?
    Should I have some kind of relationship between the main form and subform? if so what should that be? The InvoiceNO?
    Thanks

  2. #2
    Join Date
    May 2005
    Location
    Nevada, USA
    Posts
    2,888
    Provided Answers: 6
    Typically there would be a relationship on InvoiceNo, yes. On the form, that would be enforced with the master/child link properties of the subform control. The subform would only display records associated with the invoice number on the main form.
    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •