Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2015
    Posts
    1

    Question Unanswered: Enabling extensions using CREATE EXTENSION

    I am trying to add postgis to my postgresql db

    I am running Ubuntu server 14.04 with Postgresql 9.4.5, I have installed postresql ans postgis from apt-get install
    I have a db named Object.

    I tried:
    Code:
    Object=> CREATE EXTENSION postgis;
    ERROR:  syntax error at or near "EXTENSION"
    LINE 1: CREATE EXTENSION postgis;
    and

    Code:
    Object=> \dx
    The server (version 8.4) does not support extensions.
    Any ideas how to get around this?

    Gary

  2. #2
    Join Date
    Nov 2003
    Posts
    2,935
    Provided Answers: 12
    This:
    Quote Originally Posted by garynobles View Post
    I am running Ubuntu server 14.04 with Postgresql 9.4.5
    contradicts this:
    The server (version 8.4) does not support extensions.
    Apparently you did either not install 9.4 but 8.4 or you are connecting to a different installation.
    I will not read nor answer questions where the SQL code is messy and not formatted properly using [code] tags: http://www.dbforums.com/misc.php?do=bbcode#code

    Tips for good questions:

    http://tkyte.blogspot.de/2005/06/how...questions.html
    http://wiki.postgresql.org/wiki/SlowQueryQuestions
    http://catb.org/esr/faqs/smart-questions.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •