Results 1 to 2 of 2
  1. #1
    Join Date
    May 2004
    Posts
    3

    Unanswered: How to debug Stored Procedures in Data Studio V4.1.0.0

    Hi all,
    I cannot debug new Stored Procedures in Data Studio version 4.1.0.0 (even though they are corerctly deployed with the "Enable debugging" option checked).
    The following error is displayed:
    "The routine is not deployed for debug. To continue, you must deploy the routine for debug."
    Debugging of some older Stored Procedures (that were deployed using an older version of Data Studio) works OK (in v.4.1.0.0).
    Also, deploying the new Stored Procedure in the old version of Data Studio enables it for debugging - which leads me to conclusion that there must be a bug in DS.4.1.0.0.

    So, how can I deploy and debug SPs in DS.4.1.0.0?
    Any ideas?

    Kind regards, DW

  2. #2
    Join Date
    May 2012
    Location
    Canberra, Australia
    Posts
    176
    Provided Answers: 6
    I'm using 4.1.2 and if the SP is not deployed with debug you get a pop-up asking if you want it deployed with debug
    Andy

    "All parts should go together without forcing. You must remember that the parts you are reassembling were disassembled by you. Therefore, if you can’t get them together again, there must be a reason. By all means, do not use hammer.” — IBM maintenance manual, 1975 "

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •