Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2012
    Posts
    35

    Unanswered: err=-25582 Network connection is broken

    Hello,

    I have an Informix Dynamic Server Version 11.70 FC2 running on AIX 6.1 machine and i recently experienced a problem.
    The instance was working fine and out of nowhere i could see the following message on Informix log:
    "listener-thread: err=-25582: oserr=0: errstr=: Network connection is broken"

    The same message appeared for 7 minutes and despite server was On-Line during that time users could not connect to the databases.
    Note that this is a Database Server. Users are connecting through a different server - application server.
    After the 7 minutes passed the instance return to its previous state and users could connect normally.
    Note also that nothing was done in order for the instance to be accessible by the users again. It just came back without any intervention.

    Does anybody experienced a similar situation?

    Thank you

  2. #2
    Join Date
    May 2008
    Posts
    19
    Hi,

    as this seems to be a one-off situation, I can only speculate, but yes, I had some similar problems once.

    Explanation could be one of the following:
    - short outage of the DNS or network
    - application server sent an open request but instead of sending data, the connection was closed unexpectedly.

  3. #3
    Join Date
    Jul 2012
    Posts
    35
    thank you for your reply.
    so in your situation what did you do to recover this incident?

  4. #4
    Join Date
    May 2008
    Posts
    19
    Hi,

    there was not much we could do apart from checking the network itself by using a network monitor like wireshark. In this case, a network switch was failing.
    Could you still connect to the server by using one of the DBSERVERALIASES, if one exists, preferrably an icpshm connection?
    Did ssh, ping, telnet and so on still work normally?

  5. #5
    Join Date
    Jul 2012
    Posts
    35
    well this is the idea of what we will do in case that this situation re-occurs.
    I prepared a script where I do ping, dbaccess both locally from the server and remotely from a different server so when it happens again I will execute this to see what I will get.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •