I have a MAMP Pro server running on Mac OS X. It has been running fine. The default engine is InnoDB, although I have a mixture of database types on the server (myisam and innodb).

I recently installed Confluence and JIRA from Atlasssian and they for the most part work, but I've been getting an error saying:

WarningInnoDB Log File Size

What does this check do?

Checks if the innodb_log_file_size variable in your MySQL database is appropriate.


Your innodb_log_file_size of 5,242,880 is too small. You should increase innodb_log_file_size to 256M.

In the my.cnf I have this:

# The MySQL server
#port = 9999
socket = /Applications/MAMP/tmp/mysql/mysql.sock
key_buffer_size = 64M
max_allowed_packet = 512M

# table_cache only works for MySQL 5.5.x
#table_cache = 64

# If you are running MySQL 5.6.x, use table_open_cache.
#table_open_cache = 64

sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 32M

and this:

#Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /Applications/MAMP/db/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /Applications/MAMP/db/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 128M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 512M
#innodb_log_buffer_size = 256M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

When I uncomment the innodb_log_file_size the server crashes on startup. Not sure what that is.

Also, I've thought about upgrading to v 5.6 of the server, but that is kind of a pain in the ***. Just wondering how to do that with MAMP and if it is really worth it.

Thank you.