Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2009
    Gatineau, Quebec Canada
    Provided Answers: 1

    Unanswered: Database Corruption Relating to Security and Compiling

    I am busy, as a volunteer at a food bank, updating 2007 Access workstations at the food bank using my workstation at home which uses Windows 10. There are significant quirks between 2007 and 2010, but the food bank is poor). From time to time, I update the working master. I then link it to the server tables at the food bank, and compile the front ends.

    The database started either refusing to compile, or compiling but disabling all the objects (e.g., so none of the buttons worked, etc). The latter is a behaviour typical of a security problem. After much dicking around with security settings, then backtracking to functioning database versions(i.e. going to a version that compiled, then subtracting new forms, tables, etc) I found that the failure was due to a single, defective form. When I deleted the form, the problem ceased. I tried to delete all the code behind the form. It still failed (having no code). After I redid the form form scratch, (using the same object name -- "frmInfo" for it), everything compiled fine.

    Just a heads up in case anyone else runs into this problem.

    J. Smith
    Aylmer, Quebec

  2. #2
    Join Date
    Apr 2014
    Provided Answers: 23
    Yes, occasionally an object will corrupt. It's frustrating trying to figure out the problem and I've hit that same thing. The only fix is to delete that form and rebuild from scratch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts