Hello,

I want to take database backup but pg_dump is not working.

pg_dump
pg_dump: /lib/x86_64-linux-gnu/libz.so.1: version `ZLIB_1.2.5.2' not found (required by pg_dump)

I can't reinstall the postgres because there is important databases. once i get all backup i ll upgrade version.

currently my version is 9.1

Please provide solution for this.

I have read that we can remove postgresql-client and reinstall. if i do this. my databases will be lost ?

I have tried to connect remote postgres from my local pg_admin UI. but connections going timeout. i have used IP address which is of my web server. am i missing something ?

Your feedback will be more important to me.


Thanks,
Ishwar Malvi