Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2011
    Posts
    83

    Unanswered: Yes/No Check button corrupts my database.

    Hi All,
    I have a database with around 16 users and we are all using Access 2016. We are all on Windows 10. The forms, reports coding are in one database and tables in another. After a few years of no trouble, the tables database keeps corrupting (once a day now). I get every user out of the database and then repair the tables database. I have narrowed this down to a simple yes/no button. Sometimes when this button is checked, the table database corrupts.....but not everytime it is checked. I have deleted the check button from the form and added a new one.......I have deleted the form in question and replaced it with a version that is over 2 years old and it still keeps happening. What else can I try?

    Thanks
    Simon

  2. #2
    Join Date
    Apr 2014
    Location
    Kentucky
    Posts
    495
    Provided Answers: 24
    Try repair,compress,
    Then creating a new blank db,
    Import EVERY item from old db, including relationships,schema,etc.

    Try again. But it could be a conflict with componants.(check boxes,text box)
    You may need to create in a newer access version,or older version.

    It could also be a certain PC. I had to stop using 1 PC. The db worked on every PC except the 1. It never would run the db correctly. Prob due to componant conflict.

  3. #3
    Join Date
    Jan 2011
    Posts
    83
    I have started a brand new db and imported everything in. Running this one now and will see how we get on. Thanks for your time

  4. #4
    Join Date
    Jan 2011
    Posts
    83
    OK, after opening a brand new database and importing all of the tables, forms, reports and code, if has now been 3 days with no issues. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •