Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2016
    Posts
    5
    Provided Answers: 1

    Answered: Oracle RDBMS 11.2.0.4 characters issue

    Hi. I've encountered a problem trying to load the character into a varchar2 column in an 11.2.0.4 DB. The character that gets inserted is a '?'. Normally this happens when the characterset of the DB cannot handle a special character, however, the nls_characterset of the DB is UTF8 so there shouldn't be a problem with an ''. The NLS_LANG env variable is set to the same so it shouldn't be a discrepancy with the client characterset. The SQL is being run via an emcli hostcmd. I've tried running the the same SQL via TOAD and it works fine.

    Any idea what the cause could be? Thanks.

  2. Best Answer
    Posted by general_franco

    "Looks like it's a bug and there's no work around unfortunately."


  3. #2
    Join Date
    Dec 2016
    Posts
    5
    Provided Answers: 1
    Quote Originally Posted by general_franco View Post
    Hi. I've encountered a problem trying to load the character into a varchar2 column in an 11.2.0.4 DB. The character that gets inserted is a '?'. Normally this happens when the characterset of the DB cannot handle a special character, however, the nls_characterset of the DB is UTF8 so there shouldn't be a problem with an ''. The NLS_LANG env variable is set to the same so it shouldn't be a discrepancy with the client characterset. The SQL is being run via an emcli hostcmd. I've tried running the the same SQL via TOAD and it works fine.

    Any idea what the cause could be? Thanks.
    It looks like the emcli engine cannot preserve umlauts. Even when LANG and NLS_LANG environments are set on both client and target (in the script) it still doesn't work. It could possibly be related to the locale env settings -> LC_MESSAGES and LC_TYPE, but are these not covered by the LANG env var?
    Last edited by general_franco; 12-11-16 at 12:35.

  4. #3
    Join Date
    Dec 2016
    Posts
    5
    Provided Answers: 1
    Looks like it's a bug and there's no work around unfortunately.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •