Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2017
    Posts
    1

    Unanswered: Date() stopped working for 2017 data

    Hi There,

    I have been using Access 2010 as a database for transaction data generated in Excel format from our ERP system. The Excel file is manually uploaded to Access (thru Get External Data - Excel Spreadsheet wizard). I created a query that pulls transactions based on the Date() criterion and everything was working fine in 2016.

    When I uploaded the first Excel file for 2017 data, the Date() stopped working, it did not pull any 2017 transactions. However, the function is still working for any 2016 dates i.e. when I run the query with Date() for any date in 2016, it works fine. When I run the same query with the same function for any 2017 dates, nothing is generated and no error message. I created a separate Access file with 2017 data only but the Date() did not work either.

    Some of the answers in this forum suggested that the issue may be related to missing References, I checked the References but could not figure out what was missing, none of them says the word missing. This does not make sense because the same function is working for 2016 data but not 2017 data.

    Any help would be much appreciated.

    Thanks,

  2. #2
    weejas is offline Grumpy old man (training)
    Join Date
    Sep 2006
    Location
    Surrey, UK
    Posts
    1,101
    Provided Answers: 17
    Can you post some sample data and the SQL from the query?
    10% of magic is knowing something that no-one else does. The rest is misdirection.
    Beers earned: 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •