Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2017
    Posts
    2

    Unanswered: Help completing query and report

    I am getting VBA debugger in last line of code after applying a filter. I have attached the database. Please let me know how to resolve the code. What I want is to open the Form, select my options in the drop down menus, click Open Report, and it opens report with additional information on the selections I made. Right now, it gives an error when I click on Open Report. If you click on my Query and the actual report, it opens up all the records I have and doesn't filter. Please help!
    Attached Files Attached Files

  2. #2
    Join Date
    Mar 2017
    Posts
    2
    Hello, My query now works. I added in a select statement under Type_tbl and it worked. I was also able to eliminate the VBA altogether and do this query filter in a macro and open it up as a report in the command button Open Report.

    Now I have another question. Currently my tables have primary key and no duplicates for the purpose of making this work. But I will have information in my tables that will be duplicates and have to remove the primary key. When I do this, and I have 4 records all under the British category, then the Period drop down menu in my form also shows up British 4 times as a selection choice. How can I make it so that I only have British shown up once in my drop down menu in this case. thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •