Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2001
    Posts
    9

    Question Unanswered: Cannot resolve collation conflict for equal to operation

    Hello,
    i am getting the following error in SQLServer2000:-
    Cannot resolve collation conflict for equal to operation

    Sequence Of Operations :
    1. Restored a database from a SQLSERver7.0 backupfile into SQLServer2000 database

    2. Differences found when the stored proc. 'sp_server_info' was run on SQLSErver2000 and SQLServer7.0

    IDENTIFIER_CASE
    SQLSERver7.0 SENSITIVE
    SQLServer2000 MIXED


    COLLATION_SEQ
    SQLSERver7.0 :- charset=iso_1 sort_order=bin_iso_1 charset_num=1 sort_order_num=50
    SQLServer2000 :- charset=iso_1 sort_order=nocase_iso charset_num=1 sort_order_num=52


    3. For the command "select DATABASEPROPERTYEX()" in SQLServer2000
    The temporary and master database returns --> SQL_Latin1_General_CP1_CI_AS
    The restored database returns --> Latin1_General_BIN

    4. I am getting the error in a sp where data is being fetched from 2 temporary tables.
    I suppose the backupup database 'Collation' has to match the Master & temdb 'Collation'

    How do i change the 'Collation' parameter of the new database so that it matches with the tempdb database ? Will this solve the problem ?

  2. #2
    Join Date
    Oct 2001
    Location
    England
    Posts
    426
    Tempdb will use the collation of the model database when the server is started (i.e. tempdb is built).

    Use can coerce the collations used in queries to compare using a specific collation.
    = (colname collate collationname)

    You can change the collation of a database by
    alter database collate collationname
    this will change the default collation for new tables
    For existing ones I think you will have to run alter table scripts.

    These may all change the representation of the data though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •