Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2002
    Posts
    3

    Talking Unanswered: Auto fill - how to turn it off

    Hi,

    I'm using MS Access 2000 and 2002. As I fill in my data, it automatically fills in the next # in a series. How do you turn this off?

    (i.e. 1, 2, 3 - it will automatically give me a 4 my next tab over)

    Sue

  2. #2
    Join Date
    Oct 2001
    Location
    Bay Area, CA
    Posts
    117
    I guess you've got an autonumber field that assigns the next sequential number to the new record. It is set in the table. Generally these autonumber fields are added to automatically create a unique ID to the record and serve as a primary key (not always the case though), but if it is, keep in mind that when you change it you need to assign another identifier instead. If it annoys you, make it invisible in your form.

    If my assumption is incorrect, please describe you problem/application in more detail.

  3. #3
    Join Date
    Jan 2002
    Posts
    3
    Thanks Torgue for responding. Actually it's not the auto# - it's within the table as I click along from field to field. I'm logging how many tickets are written for each offense and as I tab along it will sometimes just take it upon itself to fill in the next field for me. Very frustrating and I can see no way of turning it off. I've checked every book and even MS's web site. I guess this is one of Bill's new features, but personally it's more of a pain.

    Any suggestions?

    Sue

  4. #4
    Join Date
    Oct 2001
    Location
    Bay Area, CA
    Posts
    117
    If it happens in the table itself, I have no explanation how that would happen. In a form or perhaps a query perhaps... It sound like a bug to me. I don't think Bill did this purposely to annoy you.

    My only advise is to create a new, fresh table and transefer all records to that table.

    Sorry...

  5. #5
    Join Date
    Aug 2006
    Posts
    1

    Fields in a table 1 2 3 then next field when tab over 4

    I have the same problem:

    When data is being input into a table. The table has several fields ok

    You can put in the first field 1 then the next 2 and as you tab to the next
    field the number appears automaticaly. That is a problem when you want to
    leave the next field blank ok..... because if you do not see the number going in there then it will throw off the totals ok....

    Question then is: How do you turn it off??? It has nothing to do with a
    auto number Id get it!!!

    tjfrank

  6. #6
    Join Date
    Nov 2003
    Posts
    1,487
    For all of you that feel this Auto-Fill nonsense is a pain in the a$$, well...you're all out of poopy luck. This is a built in feature and there's not really much you can do about it.

    If never the less, this really bites you then what you can do is mull over this little thought. Tables are for storing data and Forms are a pretty good and flexible interface for a ways and means of supplying that data.


    Try making a Continuous Form and design it to simulate your Table Datasheet view. Don't try and make a Datasheet Form becuase you'll just end up with the same nonsense.

    If it's any comfort...I've read somewhere that Microsoft has widely heard about this complaint and removed this feature or has implanted a means to disable it in Access 2007.


    Wonder why....

    .
    Environment:
    Self Taught In ALL Environments.....And It Shows!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •