Results 1 to 11 of 11
  1. #1
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6

    Unanswered: External image in form

    I have membership db that works fine but I need to show the member photo in an image control. The image file name is the same as the member ID number. ( ID= 12345 Image = 12345.jpg etc.) Each member record should show the correct member photo.
    The MS Access site has example code to do this. (Q210100).
    The code in Q210100 did not work for me. I assume I'm doing something wrong but don't know what.
    Has anyone tried this code? Has it worked for anyone?
    Is the code broken?
    The code is attached in .pdf.
    Thanks
    Attached Files Attached Files

  2. #2
    Join Date
    Jan 2002
    Location
    At the Edge of America!
    Posts
    55
    I see the code from Microsoft. I would like to see your code. The code from Microsoft works fine.

    You need to referance the fields in your forms and your tables.

  3. #3
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6

    You need to referance the fields in your forms and your tables.

    What do you mean by reference?
    The ID# & ImagePath fields on the form change correctly.
    But, the image stays the same.
    Per the MS example, the code is in the Northwind sample db.
    Do you want to see the whole db?

    Please advise.
    Thanks,
    Vince

    BTW, I'm running Access 2000 on Win2000.

  4. #4
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6

    External image in form

    Thanks for your response.
    What do you mean by reference?
    The ID# & ImagePath fields on the form change correctly.
    But, the image stays the same.
    Per the MS example, the code is in the Northwind sample db.
    Do you want to see the whole db?

    Please advise.
    Thanks,
    Vince

    BTW, I'm running Access 2000 on Win2000.

  5. #5
    Join Date
    Jan 2002
    Location
    At the Edge of America!
    Posts
    55
    What I was referring to is I wanted to see how you applied it to your database. Have you done this?

  6. #6
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6

    External image in form

    I have not put the MS code in my working db yet.

    I set up the code with the NW db as specified in the MS article.
    I also made a simple db with just the MS code.
    Both failed.

    The simple db is just the two tables and one form.
    The SetImagePath function is pasted in from the MS document.
    The form onCurrent & afterUpdate are set to =SetImagePath().
    The image control is unBound and set for the first photo.

    Again the text box values change correctly but the image control does not. It remains showing the first photo.
    I must have set something wrong somewhere.

    Cannot attache .mdb file so I will email you the simple db. See if it works for you.

    Again, thanks for helping me.

    Vince

  7. #7
    Join Date
    Jan 2002
    Location
    At the Edge of America!
    Posts
    55
    i have the database. What version of Access are you using~?

  8. #8
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6

    External image in form

    Access 2000

  9. #9
    Join Date
    Jan 2002
    Location
    At the Edge of America!
    Posts
    55
    I think you might have gotten confused about the image control. You need to place an image not an image control. Set its source to the pictures. Also make sure your pictures are located in the path specified.

    I am using WINNT40 my files are in a different location than MS put down. See the DB I created for you!
    Attached Files Attached Files

  10. #10
    Join Date
    Jan 2002
    Location
    Florida
    Posts
    6
    Your are absolutely right.
    Thank you, thank you, thank you.

    If you look at the MS text it says "Image Control", and I took it literately. That's where I went astray.

    FYI, I've posted this problem with the code on several Access forums starting several months ago. There were many look-see and many code downloads but you are the only one who responded and found my error.

    Thanks again,
    Vince

  11. #11
    Join Date
    Jan 2002
    Location
    At the Edge of America!
    Posts
    55
    Glad I could Help you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •