Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2002

    Unanswered: BMP EJB to DB2 - SQL3282N - supplied credentials not valid

    While writing this post, I've solved my own problem, but since it took me hours of going round in circles to work out what was wrong, I'll share my experience.

    I'm using javax.sql.DataSource to get a connection to a DB2 database. I get the following exception from WebSphere:

    Exception: [IBM][CLI Driver] SQL3282N The supplied credentials are not valid.

    My assumption was that the username or password was invalid. Seems reasonable.

    Actually the problem is that I had mis-typed the database name in the JNDI data source configuration.

    I kind of see what DB2 might be getting at. Perhaps it means "the credentials you supplied are not capable of accessing the named object". Fair play. But why not tell me that!

    Perhaps I installed the "Psychic English" version by accident :-)

  2. #2
    Join Date
    Jun 2002

    I'm trying to get access to a local UDB2 database through the IBM WMQI product. I've defined an ODBC datasource "DB2DS". When I tried to reference a table through the defined datasource, I get this SQL error. I've checked the db2cli.ini file and the db name is spelled correctly in there. Does anyone have any idea why else this problem may be occurring ? Thanks for anyone's help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts