Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2002
    Posts
    2

    Post Unanswered: combo box problem

    Hi All!
    I have a problem, that is frustrating me for hours!

    On a subform i have a combo box. Its values come from a table.
    I want the box to behave that way: If a user chooses a certain value from the box, some fields on the subform should hide.
    I wrote a procedure for the OnChange event.

    The problem:
    If the combo box is unbound, it works great. The problem: If it is bound, and that is my intention, it doesn't work. And I can't figure out why.
    Any ideas? Any help would be greatly appreciated!

    Kind regards, Manuel Schueren

  2. #2
    Join Date
    Nov 2001
    Posts
    336
    Try to put your code in AfterUpdate event.

    HTH

  3. #3
    Join Date
    Feb 2002
    Posts
    2
    Hi HTH,
    thanks for your advice, but also changing the code to AfterUpdate didn't work.
    In the meantime, i have a (the?) solution for my problem:
    Thy datatype for the field in the underlying table was CHAR. When i changed it to VARCHAR, everything worked fine, even with the OnChange code.
    Without a clue, but satisfied for now,
    Manuel

  4. #4
    Join Date
    Nov 2001
    Posts
    336
    Hi Manuel,

    I am glad that you solved the problem.
    By the way, my name is Igor, and HTH - just abbreviation of "Hope That Helps".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •