Results 1 to 3 of 3

Thread: Db2gov

  1. #1
    Join Date
    Feb 2002

    Unanswered: Db2gov

    Any idea about DB2GOV command?
    i have written config file for that ,but i am getting an error is not able
    to find the file.The file is on sqllib directory .I have tried all

    What i am trying is...
    C:\>db2gov start sample mygov.cfg mygov.log
    OpenEvent1:The system cannot find the file specified.
    db2gov: GOV1062N Unable to start governor at node "0". rc = "2".


  2. #2
    Join Date
    Mar 2002
    I work with DB2 UDB V7.1 running on AIX, so these suggestions may not be valid for Windows-based DB2 UDB, but here goes anyway.

    1) Make sure that the user that is issuing the db2gov command has sufficient rights / authority (permissions in AIX terms - not sure what the Windows equivalent is) to access the mygov.cfg (& mygov.log) files.

    2) Make sure that the sqllib is defined in the path (AIX term - not sure of Windows equivalent) for the user issuing the db2gov command.

    Good luck & let us know how the problems is resolved.

  3. #3
    Join Date
    Oct 2001

    Tried out solution from your colleague

    Here's the solution:

    1.Create a cfg file , as you have already done with.
    Save it in \\installation dir\SQLLIB
    (say governor.cfg)

    2.To start the governor attach to the instance as the admin owner
    and come to the path \\installation dir\SQLLIB.
    >db2gov start dbname governor.cfg govlog.log

    where govlog.log is the log file you create as output.

    3.To display governor log info come to the path \\installation dir\SQLLIB.
    >db2govlg govlog.log rectype FORCE


    4.To stop the governor attach to the instance with admin owner
    and come to the path \\installation dir\SQLLIB.
    >db2gov stop dbname

    Hope this would be different then all that you have tried. This will surely work as i have practically tried this out.

    Prashant G Dahalkar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts