Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2002

    Unanswered: Canít enable database for full-text searching

    When trying to create a new full-text catalogue for a database through enterprise manager the following error is generated:

    The Microsoft Search service cannot be administered under the present user account

    When attempting to enable a database for full-text searching by running the stored procedure "sp_fulltext_database" the following error message is recieved:

    Server: Msg 7635, Level 16, State 1, Procedure sp_fulltext_database, Line 46
    The Microsoft Search service cannot be administered under the present user account

    The user account that the SQL service is running under has full administrative rights (including the privileges such as log on locally/as a batch/as a service etc - the SQL BUILTIN\Adminstrators login also exists) and the MSSQL and MS Search services have been stopped and started to ensure that the system account does have control of the MS Search service.

    Although the text of the error message refers to user rights, line 46 of the stored procedure refers to the DBCC CALLFULLTEXT function and so it appears that the process is actually falling over when trying to drop catalogues.

    The server was upgraded from SQL Server 6.5 to SQL Server 2000 and the Full-Text Search component was selected. However it was noticed that the folders Config, Projects and GatherLogs were not present under the following directory:

    C:\Program files\Microsoft SQL Server\MSSQL\FTData\SQL Server\

    (It was attempted to reinstall the Full-Text Search component from the SQL 2000 CD but as the component was already installed this wasnít possible)

    The relevant config files, including the schema.txt, were then copied to the above location and it was ensured that the schema.txt file was the same in both the above location and the MSSQL\Binn folder (and on the SQL 2000 CD). But this has had no effect.

    It has also been noticed that there is no registry key relating to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\SQLFTSearch\Setup\Schema

    However we have another server (which was a SQL 2000 install, as opposed to an upgrade) which also doesnít have this registry entry and that server isnít experiencing any problems with full-text search/indexing.

    Can anyone suggest any other possible fixes before we resort to reinstalling SQL server?


  2. #2
    Join Date
    Feb 2002
    Have you tried to run the stored procedure or sp_fulltext_database using query analyzer ?

  3. #3
    Join Date
    Feb 2002
    I'd be looking at the following closely ( assuming you may not have checked these out already ):

    I'd be checking technet first as it sounds awfully like a upgrade "undocumented" type problem.

    Apart from that, sounds like you have done everyting else right.

    Try setting the SQL Server account to run under a domain account, but make sure you set the startup account to be the same in the Server Properties tab in EM as the account you use when you alter the startup account in Services. This is for the benefit of the Full Text service.

    Post back if probs.


  4. #4
    Join Date
    Mar 2002


    Thanks for your suggestions

    ....but we resorted to reinstalling SQL which has worked, so it appears that there might be problems with the full-text feature if you've upgraded to sql 2000 from 6.5 (as opposed to a straight 2000 install).

    (we retained the databases by detaching them and copying the .mdf/.ldf files to another location. Then once the new install of SQL 2000 was complete we re-attached the databases - NB. the detach/attach method doesn't cover DTS packages. Also if specific users are created for a DB after reattaching you might need to delete them from the DB user section, then recreate them in the security logins section)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts