Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2002
    Posts
    1

    Unanswered: run-time error 2465

    My database has started coming up with the following error:

    "Run-time error '2465' Microsoft access can't find the field '|' referred to in your expression. "

    I have tried everything I can think off with this. I have used documentor to document the entire database and every object in it, then searched the results and I didn't find | once.

    That made me think it was a glitch. I have gone through the database and deleted everything bar the main form and main table and still get the same result. I have then created a new main form and copied everything across to it - same error. I have tried compacting and repairing the database.

    the error occurs when I use the line:
    docmd.openquery [.....]
    It doesn't seem to get as far as trying to open the query, since when I was deleting everything, the error message didn't change even after I deleted the query I was trying to open. Most annoyingly, the queries all run fine when just double clicking on them to run them.

    I am lost for ideas now - anybody out there got any???

  2. #2
    Join Date
    Feb 2002
    Posts
    403
    Try

    Docmd.OpenQuery "Name of Your Query"

    The error 2465 sometimes means the [] are not valid required or what have you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •