Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2002

    Unanswered: Help on error msg CLI0647E

    One of our app. developers get the following error message when trying to connect to a database (db2u) on mainframe from is client:

    <Mar 14, 2002 12:59:43 PM GMT+01:00> <Error> <JDBC> <Cannot startup connection pool "SIS" [IBM][JDBC Driver] CLI0647E Error allocating DB2 environment handle, rc=-1.>

    The configuration of the connection pool is like this:
    <JDBCConnectionPool DriverName=""
    MaxCapacity="10" Name="SIS"
    Targets="myserver" URL="jdbc:db2:db2u"/>

    Other configuration parameters:

    I haved tried to reinstall the db2 runtime client, but the same error still appears. Tried to search the IBM Knowledge Base, but could not find a solution.

    Anybody any hints ?
    Odd B. Andersen
    ErgoSolutions AS
    Oslo, Norway

  2. #2
    Join Date
    Nov 2002

    I had this problem on a Solaris 7 system. We fixed the problem by executing the db2profile script in the user's login script. The db2profile script can probably be found in the installation directory's sqllib directory. This script sets up several environment variables required by the DB2 client software.

    Be advised that you must also comment any statements that deal with the IFS environment variable as this will replace certain characters in your PATH with ':'.

    Hope this helps,

  3. #3
    Join Date
    Sep 2003
    Hi Tom,

    I too faced the same problem when I tried to create a jdbc connection pool to establish connectivity between weblogic 6.1 and DB2 7.2 using Type 2 driver. I executed the db2profile on the user's login as you have suggested. Still I get the same error message (<Error> <JDBC> <Cannot startup connection pool "MyDB2JDBCPool" [IBM][JDBC Driver] CLI0647E Error allocating DB2 environment handle, rc=-1.>) when I start the weblogic server. Any help on this is appreciated.

    Thanks in advance,

  4. #4
    Join Date
    Oct 2003
    Hi everybody,
    I've just lost more than half working day around the same problem.
    I was playing with some client configuration in order to speed-up connections to DB2 server and suddently Control Center tool, as well as Command Center tool stopped working: all the times I tryed to connect I received the very frustrating CLI0647E message, with rc = -1 (so helpful!).

    There's not apparent cause-effect relationship in what I've experienced (and searching for info at IBM site is, in my opinion, one of the worst nightmare could happen). I don't know if what I've discovered can be helpful to you, anyway, here you are my report:

    - I'm working on a client PC running Win2000
    - I've defined several ODBC data sources to DB2 server (UNIX), one for each database I need to access to
    - I use Ms Access to retrieve data from DB2 through ODBC
    - I've changed an 'advanced parameter' setting ON ONE data source only (that was enough, but I discoverd it much later).

    - Parameter I've changed is MULTICONNECT (folder 'Transaction' in 'advanced' settings page): default value is 'Not shared'; I've set it to 'Shared' (I'm not sure these are the right words, as my client's language is italian).
    - Control Center and Command Center stopped working.
    - Ms Access linked tables started to be 'confused' (i.e. pointing to the same physical data, errors in data, etc.).
    - Switching back that damned parameter to 'not shared' solved everything!

    - Main difficulty was that it has not been the only change I've done before experiencing problems: I've also reconfigured DB2 Systems and Instances more times and, since I've also received some warnings when quitting Control Center after changes, that was the logical source of problems.

    Changes on ODBC data source DOES effect on Control Center startup, and error message mentions a wrong enviroment variable setting... nice challenge!

    I guess that this is a bug, probably solved by some patches, but so far I'm not in the mood to search for it!

    Sorry for the lenght of this message, but I had to vent my anger in some way.

    I hope this will help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts