Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2002
    Posts
    2

    Post Unanswered: DTS: No steps have been defined for the transformation package.

    Hi,

    I'm trying to run a few DTS packages in SQL Server 2000 using ASP and I'm getting the error below.

    "Microsoft Data Transformation Services (DTS) Package (0x800403ED)
    No steps have been defined for the transformation package."

    Does anyone know all the possible reasons why this error occurs?

    I've read that stop and starting the SQL service will do the trick but I've had no luck with that. I've also read that it could be a problem with disk space but I doubt that as I have more than 1GB available.

    Oh...one thing I havent mentioned is that when I was doing a prototype for this...I created a new project with Visual Interdev and did all the ASP programming there to execute the package and that works fine but when I tried to incorporate the code into a different project...then that's when I get the error message above.

    If anyone could help me out...that would be greatly appreciated!

    Thanks.

  2. #2
    Join Date
    Feb 2002
    Posts
    2,232
    Would you please provide your code and mark which line your code is failing on ? Have you tried to access the properties of the package in your asp code as a debug measure ???

  3. #3
    Join Date
    Mar 2002
    Posts
    2
    It fails on when it calls the Execute method. All the other properties can be accessed and work.

    I found out what was causing the problem and it's basically got to do with a setting in IIS (I'm using IIS 5.0). I'm not sure if this is a problem that is specific to the system I'm running here but when executing a DTS package from ASP...you have to make sure that the 'Application Protection' setting in IIS is set to 'Low (IIS Process)'. It will NOT work with any other setting.

    Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •