Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2002
    Posts
    9

    Question Unanswered: olap: writeback tables

    i am having trouble getting the update cube statement to write data to the writeback table.

    i am querying the cube using "MDX Sample Application", connecting to a ROLAP real-time cube. Writeback IS enabled, the writeback table IS created. The dimension tables are parent-child.

    the following mdx query executes without error, but no values are written to the writeback table.

    update cube [cube10]
    set (
    [Local Currency],
    [P04],
    [Base Dimension 6],
    [Base Dimension 7],
    [O2100],
    [A3820],
    [Actual 01/02])
    = 10
    use_equal_allocation

    I have tried disconnecting from the database and re-connecting in case there is a local cache in 'MDX Sample Application'

    When i write data directly to the writeback table with SQL and reprocess the cube, then the new value IS processed correctly.

    i would appreciate any ideas
    thank you.

  2. #2
    Join Date
    Jan 2002
    Location
    FRANCE
    Posts
    15

    Lightbulb

    Do you have used a transaction ?
    Try to commit your update.

  3. #3
    Join Date
    Mar 2002
    Posts
    9
    thanks for that,
    but how do i do that. there is no commit command in mdx that i can find!

    excuse my ignorance, i new to mdx,

  4. #4
    Join Date
    Jan 2002
    Location
    FRANCE
    Posts
    15
    The commit is not a MDX command, it's a function of your connection.
    For example :

    Query="update cube [cube10]
    set (
    [Local Currency],
    [P04],
    [Base Dimension 6],
    [Base Dimension 7],
    [O2100],
    [A3820],
    [Actual 01/02])
    = 10
    use_equal_allocation"

    ActiveConnection.BeginTrans
    ActiveConnection.Execute Query
    ActiveConnection.CommitTrans

    Have a nice day !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •