Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2002
    Location
    Germany
    Posts
    2

    Question Unanswered: SQL1084C Shared memory segments cannot be allocated

    I have 3 databases. Whenever I want to activate
    the third one (it doesn't matter in which order)
    I get this error message.

    I tried to change the DB2 parameters but it
    doesn't help.

    Does anyone know what I have to do ???

    ciao, Ralf

    PS:
    I changed:
    util_heap_sz, buffpage, esotre_seg_sz, dbheap,
    catalogcache_sz, backbufsz, restbufsz, fcm_num_buffers

    System RedHat 7.0; 256 MB real + 512 MB swap memory

  2. #2
    Join Date
    Mar 2002
    Location
    Germany
    Posts
    2

    Problem solved

    The answer was easy:

    kernel parameter MSGMNI was not set

    I had to change /proc/sys/kernel/msgmni from 16 to 128 or larger
    and I have to put "kernel.msgmni = 128" into /etc/sysctl.conf
    I found the solution in
    http://www.linux.org/docs/ldp/howto/...O/perform.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •