Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2002
    Posts
    11

    Unanswered: Oracle 8i JDBC thin Driver problem.

    Hi ,

    I'm trying to access an Oracle 8.1.7 remotely from
    a Java Program on Win 2k. I have downloaded the
    classes111.zip for Oracle 8.1.7 for use with jdk 1.1.x
    on Win NT from the Oracle technet site and placed it
    in my classpath. The java program compiles too absolutely
    fine. But I get the following error at run time.

    java.lang.IncompatibleClassChangeError: Unimplemented interface method
    at oracle.jdbc.driver.OracleDriver.getConnectionInsta nce(OracleDriver.ja
    va)
    at oracle.jdbc.driver.OracleDriver.connect(OracleDriv er.java)
    at java.sql.DriverManager.getConnection(Compiled Code)
    at java.sql.DriverManager.getConnection(DriverManager .java:163)

    Any body has come across this ? Any help on this would be really really
    appreciated.

    Thanks,
    Amit

  2. #2
    Join Date
    Mar 2002
    Location
    PUNE,INDIA
    Posts
    2
    Hi ,

    I think there is a version mismatch problem.So it is better to use
    JDK1.3 which is free at Sun site.I have been using it for quite some time.I think you need to place classes12.zip in the classpath as it contains the driver.I dont remember classes111.zip.What you can do is just unzip the classes111.zip file and see if it contains the oracle driver or not.Otherwise put classes12.zip in the class path which comes with oracle8.1.7 If the problem still persists put translator.zip and runtime.zip in the classpath also.First run a simple program to connect to oracle and get one resultset from any table firing a query.

    For further query please feel free to mail at mailto:nirmalya_mishra@infy.com

    Cheers.

    Nirmalya Mishra
    Infosys Technologies Limited
    India

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •