Results 1 to 14 of 14
  1. #1
    Join Date
    Mar 2002
    Posts
    2

    [IBM][CLI Driver] SQL30081N

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'
    [IBM][CLI Driver] SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "10060", "*", "*". SQLSTATE=08001
    /selfscan/sswadmin/menus/exec/cmsea.asp, line 1908

    This error appear when i try to open a connection.
    But what does it means

  2. #2
    Join Date
    Jan 2002
    Location
    USA
    Posts
    53
    you must use

    Db2 update dbm cfg using svcename service_name

    to setup your correct servicename.



  3. #3
    Join Date
    Feb 2003
    Posts
    5
    What did you update the service name to, or where do i find that out?

    Originally posted by ljrong
    you must use

    Db2 update dbm cfg using svcename service_name

    to setup your correct servicename.



  4. #4
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,649
    You will have to define a service/port in /etc/services file ...
    Eg ...
    db2cdb2inst1 50000
    db2idb2inst1 50001

    and then

    db2 update dbm cfg using svcename db2cdb2inst1

    or

    you can do

    db2 update dbm cfg using svcename 50000

    without adding anything to /etc/services ...

    Technically speaking, using either makes no difference ... But my recommendation is to use the first method as it provides better documentation of the ports used on your system ...

    HTH

    Sathyaram

    Originally posted by darrentk
    What did you update the service name to, or where do i find that out?

  5. #5
    Join Date
    Feb 2003
    Posts
    5
    sathyaram_s
    This was done on the installation. Did you have problems after that, or do you think it could be related to a TCP/IP / network problem? I really appreciate your feedback . . .

    Originally posted by sathyaram_s
    You will have to define a service/port in /etc/services file ...
    Eg ...
    db2cdb2inst1 50000
    db2idb2inst1 50001

    and then

    db2 update dbm cfg using svcename db2cdb2inst1

    or

    you can do

    db2 update dbm cfg using svcename 50000

    without adding anything to /etc/services ...

    Technically speaking, using either makes no difference ... But my recommendation is to use the first method as it provides better documentation of the ports used on your system ...

    HTH

    Sathyaram

  6. #6
    Join Date
    Mar 2003
    Posts
    5

    SQL30081N error code 10060

    Does any know WHY? this happens ?

  7. #7
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,649

    Re: SQL30081N error code 10060

    Is you DB2COMM variable set to TCPIP ?

    To check

    db2set -all

    to set

    db2set DB2COMM=TCPIP

    Stop/start db2 ...

    then check

    netstat -an | grep <port-no> (Unix)
    or
    netstat -an | find "<port-no> (Windows)

    and check whether it is LISTENING...


    Cheers

    Sathyaram

  8. #8
    Join Date
    Mar 2003
    Posts
    5
    Yes it is set to TCP/IP a little history I am connecting to db2 mainframe from db2 server. Happens intermitantly....what can I check for besides the DB2comm/
    Thank you

  9. #9
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,649
    Your communication link ...

    10060 is a timeout error ...

    Cheers

    Sathyaram

    Originally posted by xpe123
    Yes it is set to TCP/IP a little history I am connecting to db2 mainframe from db2 server. Happens intermitantly....what can I check for besides the DB2comm/
    Thank you

  10. #10
    Join Date
    Mar 2003
    Posts
    5
    what about setting the querytimeoutinterval = 0 will that help me? In the DB2CLI.ini file

  11. #11
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,649
    This error is not a query timeout, it is a TCPIP communication timeout ...

    At the client end, you will be getting Processing cancelled due to an interrupt error if the quey times out ....

    Anyway, doesn't harm checking this option also, provided, your environment will be able to cope ...

    Cheers

    Sathyaram

    Originally posted by xpe123
    what about setting the querytimeoutinterval = 0 will that help me? In the DB2CLI.ini file

  12. #12
    Join Date
    Mar 2003
    Posts
    5
    Nd the only thing I check is the db2 Comm ? How again do I chcek that?

  13. #13
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,649
    If this is an intermittent problem, I'll recommend to check your network ...

    Speak with your network administrator,who should be able to help ...


    Cheers

    Sathyaram

    Originally posted by xpe123
    Nd the only thing I check is the db2 Comm ? How again do I chcek that?

  14. #14
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    Angry [SQL30081N] error code(s): "10061"

    @sathyaram_s:
    Hi,

    I have n e a r l y the same problem like "msalvador" and I tried all your instructions, but I can't still connect to my database and I hope you can help me.

    Here is some information about my p r o b l e m :
    I installed an DB2 v8.1 on Solaris and I try to connect to it with my client on win XP..
    This is my konfiguration client- and serverside


    (1) d b 2 get dbm cfg :
    --------------------------------------------
    (SYSADM_GROUP) = DB2GR
    (AUTHENTICATION) = SERVER
    (TRUST_ALLCLNTS) = YES
    (CATALOG_NOAUTH) = NO
    (SVCENAME) = db2service
    (DISCOVER) = SEARCH
    (DISCOVER_COMM) = TCPIP
    (DISCOVER_INST) = ENABLE

    (2) n e t s t a t -an | grep 50000 :
    --------------------------------------------
    *.50000 *.* 0 0 49152 0 LISTEN

    (3) information serverside (d b 2 c c ):
    --------------------------------------------
    S y s t e m :
    Name = VSISDB1
    Nodename = VSISDB1
    operating system = Solaris
    Typ = DB2 Version 8
    Protocoll = LOCAL
    Protocollparameter = instancename =dasusr1

    (4) D B 2 - Message:
    --------------------------------------------
    SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "10061", "*", "*". SQLSTATE=08001

    I get the error-message, if I try to konfigure the connection to my database with the konfiguration-assistent:

    (5) K o n f i g u r a t i o n for the assistent c l i e n t - s i d e :
    --------------------------------------------
    1. Protocoll = TCP/IP
    2. TCP/IP: Hostame = vsisdb1.host.de
    Servicename = db2service
    Portnr. = 50000
    3. Database: Databasename = benutzer
    Databasealiasname = benutzer
    4. Nodeoption: Operating System = Solaris
    Name of remote instance = db2inst1
    5. Standartguideline: Systemname = vsisdb1.host.de
    Hostname = vsisdb1.host.de
    Operatingsystem = Solaris

    Please help me, our administrator is on holiday and I have to fix the problem

    Thank you in advance
    Last edited by savas; 07-25-03 at 09:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •