Results 1 to 3 of 3

Thread: Error SQL0970N

  1. #1
    Join Date
    Feb 2002
    Posts
    12

    Question Unanswered: Error SQL0970N

    Hello,
    I took a online backup of an db2 db from our production server. am trying to restore it on a fresh (fresh db2 installed) server. I followed the following procedure:-
    1) I created a database PROD (the db name is same as the backed up db name).
    2) I created the log file folder and tablespace container folders on the new machine.
    3) i tried restoring using the "restore db PROD from c:\restore without rolling forward" command.
    I got the following error "SQL0970N The system attempted to write to a read-only file. SQLSTATE=55009".
    I checked all files but no file or folder is read only.
    Could u please help me with a solution. Is there a better way of restoring a complete Online backup?
    Thanks in advance...
    gurudatt.

  2. #2
    Join Date
    Mar 2002
    Posts
    17
    You could try using db2move instead.

  3. #3
    Join Date
    Feb 2002
    Posts
    12

    Error solved.

    I did find out that the error was due to an OS (Win2000) problem. I had renamed a drive (Drive E to Drive D) and not formatted it. Sue to this i got the read only error.
    It got solved when i formatted the drive..
    Thanks all, for replying back.
    Regards
    Guru

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •