Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2002
    Posts
    1

    Unhappy Unanswered: PG 7.2 install on RH7.0

    Quick question ... trying to install PG 7.2 (on RH7.0) and I get the following message :

    rpm -i --test postgresql-7.2-1PGDG.i686.rpm
    error: failed dependencies:
    libcrypto.so.0 is needed by postgresql-7.2-1PGDG
    libk5crypto.so.2 is needed by postgresql-7.2-1PGDG
    libkrb5.so.2 is needed by postgresql-7.2-1PGDG
    libreadline.so.4 is needed by postgresql-7.2-1PGDG
    libssl.so.0 is needed by postgresql-7.2-1PGDG

    I've have installed :
    - openssl-0.9.6-9.i386.rpm
    - krb5-libs-1.2.2-12.i386.rpm

    Can somebody please advise what I'm missing ??? (7.1.3 is currently installed and working - do I need to force an un-install ... no DBs to be unloaded / re-loaded).

    Thanks.

  2. #2
    Join Date
    Sep 2001
    Location
    Vienna
    Posts
    400

    Problem

    You will have problems if you are using 2 rpm-versions of postgres

    cause one version needs other libs and with the rpm you cannot change this
    it is better you compile the new postgresql.

    If you don't need the 7.1.3 then remove it from the system it is possible to run severel postgres clusters at once but then you need to take a closer look at the config stuff.
    http://www.postgresql.org
    --Postgresql is the only kind of thing--

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •