Results 1 to 1 of 1
  1. #1
    Join Date
    Apr 2002
    Posts
    16

    Unanswered: Immediate help needed to restore log!

    Hi,
    I do log shipping executing jobs that
    backup db and log WITH INIT( overriding),
    copy them to another server and then
    call the sp to restore db and log on the second server.
    I encounter the error restoring log:

    Server: Msg 3013, Level 16, State 1, Line 1
    RESTORE LOG is terminating abnormally.
    Server: Msg 4326, Level 16, State 1, Line 1
    The log in this backup set terminates at LSN 9000000009000001, which is too early to apply to the database. A more recent log backup that includes LSN 9000000020300001 can be restored.

    I tried detaching and reattaching db with/without log; I tried backup with no_truncate/no_log, etc- nothing seems fixing my problem.

    I deleted db and then created a new one with the same name to test, then I tried to backup, copy to another server, restore- and again I had the same problem! It looks like even when I delete the db there is still an entry in the db for the deleted db's LSN. Any ideas how to rid it?

    I deleted physical logs from the db and ran DBCC LOGINFO(db) just to find the 4 old log trans. What is the way to delete them?

    Please help!
    Last edited by elel; 04-11-02 at 13:09.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •