Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2002
    Location
    west haven
    Posts
    33

    Unanswered: Java Runtime error during Oracle applic install

    Hello DBA's (sorry if it is a bit long)

    1. I am trying to install an Oracle App on a SUN SPARC 20 with 256 MB / 9.1 GB.

    2. I installed Oracle 8i 8.1.6.2 EE completely and built the DB using Oracle Universal Installer. So the Java components and runtime were also installed I presume.

    I have it in /usr/java1.2 with links made during Oracle 8i install.

    3. Did post installation according to the manual.

    4. Did pre-installation for install of Oracle Clinical application.
    5. Put the OC CD into the drive and typed install.sh as requested.

    Error: The Java Runtime environment was not found at
    . . / .
    ./stage/Components/oracle.swd.jre/1.1.8.10/1/Datafiles/Expanded/solaris/bin/jre
    Hence the universal installer cannot be run.

    I am struggling for 2 months now and I am hoping that some guru will wipe out the frustration and anxiety that has made my hair grey. I have also included the contents of the oraparam.ini for Oracle 8i and Oracle CLinical. They look almost the same but for some reason, the Oracle Universal installer does not seem to work for the Oracle Clinical installation.

    What could be the reason for this Jav runtime Error?. I checked the web and other sites, but no conceivable answer. I have no access to Metalink. What do I have to do to make the universal installer work?.

    Your help is really really appreciated.

    ==============================================
    ORAPARAM.ini used when installing Oracle 8i 8.1.6.2

    [Oracle]
    DISTRIBUTION=TRUE
    SOURCE=../stage/products.jar
    JRE_LOCATION=../stage/Components/oracle.swd.jre/1.1.8.10/1/DataFiles/Expande
    d/jre
    OUI_LOCATION=../stage/Components/oracle.swd.oui/1.7.0.18.0A/1/DataFiles/Expa
    nded
    HLP_LOCATION=
    EWT_LOCATION=
    DEFAULT_HOME_LOCATION=
    NLS_ENABLED=FALSE
    NO_BROWSE=/net
    JRE_MEMORY_OPTIONS=-mx48m

    [IMAGES]
    FILE1=images/o8i_1.gif
    FILE2=images/o8i_2.gif
    FILE3=images/o8i_3.gif
    FILE4=images/o8i_4.gif
    FILE5=images/o8i_5.gif
    FILE6=images/o8i_6.gif
    FILE7=images/o8i_7.gif
    FILE8=images/o8i_8.gif
    ==============================================
    ORAPARAM.ini used when installing Oracle Clinical 4i

    [Oracle]
    DISTRIBUTION=TRUE
    SOURCE=../../stage/products.jar
    LICENSE_LOCATION=
    JRE_LOCATION=../../stage/Components/oracle.swd.jre/1.1.8.10/1/DataFiles/Expa
    nded
    /jre
    OUI_LOCATION=../../stage/Components/oracle.swd.oui/1.7.0.19.0/1/DataFiles/Ex
    panded
    JRE_MEMORY_OPTIONS=" -mx32m"
    DEFAULT_HOME_LOCATION=
    DEFAULT_HOME_NAME=OUIHome
    NO_BROWSE=/net
    HLP_LOCATION=
    EWT_LOCATION=
    NLS_ENABLED=TRUE
    BOOTSTRAP=FALSE
    OUI_VERSION=1.7.0.19.0

    [IMAGES]
    FILE1=images/installAd0.gif
    FILE2=images/installAd1.gif
    ==============================================

  2. #2
    Join Date
    May 2002
    Location
    Phoenix, AZ
    Posts
    24
    I noticed that your your ORAPARAM.ini used for Clinical has an extra ../ prefixed to the JRE_LOCATION and OUI_LOCATION when compared to the values used to install Oracle 8i.

    Best Wishes,
    Troy

  3. #3
    Join Date
    Jan 2002
    Location
    west haven
    Posts
    33
    Well, that is the way the hierarchy of the directory has been structure on the CD.

    However, I have now executed the Oracle Universal installer from the HDD from the directory where I installed it when I INSTALLED Oracle 8i.

    Since I copied the contents of the Oracle Clinical CD onto the HDD, I specified the source for the products.jar file. and left the destination HOME directory as default ($ORACLE_HOME).

    It brings up the list of products to Install. I then selected OC Unix server 4.0.0.0. It begins to load and install but comes out with some

    Java.io.NULLpointer exeception at ......


    Java.lang.NULLpointer exeception at

    I reckon that this is a problem with Solaris 8 when I should use Solaris 2.6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •