Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2002

    Unanswered: Error "There is an invalid use of . (dot) ..." in subsubreport

    I have some complex reports, currently set up as follows:

    R1 (report)

    R2 (report)
    DeliveryTotals (subreport)

    In R2, code is used to check a subreport field's value:

    If Me![DeliveryTotals].Report![TotalDelivery] = 0 Then
    End If

    I want to nest R2 within R1; Access allows me to do this physically. However, when I run the report, I get error 2447 "There is an invalid use of the ' (dot) operator", on the same line of code.

    Is there a simple solution to this? I've tried everything I can think of, and spent 2 days searching the Web - any help would be appreciated.

    Andrew Merton,
    New Zealand.

  2. #2
    Join Date
    Feb 2002
    Try retyping Me![DeliveryTotals].Report![TotalDelivery] using the autocorrect features and see how it might change.

    Try moving the starting point for the if statemetn to a different location and see if by activating somewhere else the probelm, repeats or is cured.

  3. #3
    Join Date
    Jun 2002


    Thanks for the reply!

    However, I did some further investigation(!) and discovered that the problem was in not the code, but the formula behind the column. The formula was referring to [Reports]![R2].Report![SomeField]. Since R2 is no longer the top-level report, I had to change the formula to [Reports]![R1]![R2].Report![SomeField], and then it was all happy.

    Andrew Merton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts